Commit 36651ca1 authored by Marc Willmann's avatar Marc Willmann
Browse files

[TASK] Use dependencies in respective build chains only

parent 47409554
Pipeline #258 passed with stages
in 4 minutes and 5 seconds
......@@ -25,11 +25,9 @@ stages:
- php composer-setup.php --no-ansi --install-dir=/usr/bin --filename=composer
- php -r "unlink('composer-setup.php'); unlink('installer.sig');"
- composer require "${TYPO3_VERSION}" --update-with-dependencies
- composer require nimut/testing-framework
- composer require squizlabs/php_codesniffer
- composer require codeception/codeception:^3.0
script:
- vendor/bin/codecept run unit
- vendor/bin/phpcs --standard=PSR2 --extensions=php --severity=20 Classes
# Build in PHP 7.1 and TYPO3 8 (latest stable release)
......@@ -81,7 +79,7 @@ codequality:
- php -r "if (hash_file('SHA384', 'composer-setup.php') === trim(file_get_contents('installer.sig'))) { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
- php composer-setup.php --no-ansi --install-dir=/usr/bin --filename=composer
- php -r "unlink('composer-setup.php'); unlink('installer.sig');"
- composer require --no-dev squizlabs/php_codesniffer
- composer require squizlabs/php_codesniffer
script:
- vendor/bin/phpcs --standard=PSR2 --extensions=php --severity=20 Classes
......
......@@ -11,11 +11,6 @@
"require": {
"typo3/cms-core": "^8.7.10 || ^9.5.2"
},
"require-dev": {
"namelesscoder/typo3-repository-client": "^1.3",
"squizlabs/php_codesniffer": "^3.0",
"codeception/codeception": "^3.0"
},
"autoload": {
"psr-4": {
"MarcWillmann\\Rsvp\\": "Classes"
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment